Willkommen in Paulchens Foren!
Forum > Excel & VBA > Fragen zu Excel/VBA > Dynamischer Substring UserForm
Hier kannst Du Fragen speziell zu Deinem Problem stellen
In diesem Board befinden sich 1682 Themen.
Die Beiträge bleiben immer erhalten.
Es wird moderiert von P@ulchen.


 Dynamischer Substring UserForm Zitat
12.4.2019 - 14:50 Uhr
Posts


Hallo zusammen,

Ich bin im Moment daran ein kleines Programm zu schreiben für die Einlagerung von Waren.
Hierbei habe ich folgendes Problem. Ich habe eine UserForm kreiert, wo Serialnummer und der Typ eingescannt werden können in die User Form. Wenn ich den Barcode vom Typ scanne dann ist dieser von der Logik her nach folgendem Muster aufgebaut: (Serialnummern#Typ) Ich will aber nur den Typ nach dem hashtag haben. In Excel schaffe ich das mit einer Formel folgendermaßen, wenn der Text in Zelle A1 steht: =WENN(A1="";"";TEIL(A1;FINDEN("#";A1)+1;100)). Bekomme ich das auch in der Textbox dynamisch beim scannen hin?

Hier ist das Beispiel:

SN des Scans: 010014332#802R020.000 --> Nach Anwendung der Formel: 802R020.000